Problem with make on Linux

Malleus94
Posts: 1
Joined: Fri Aug 11, 2017 10:55 am

Problem with make on Linux

Postby Malleus94 » Thu Aug 17, 2017 4:30 am

Hello everyone

I'm new to this forum and to ARtoolkit. I have to install and use it on Linux for a university project in September, but until now it my attempts have been useless.
I'm trying to install ARtoolkit 5.3.2 on a Ubuntu Mate 17 I set up on Virtualbox. I chose the 5.3 release of ARtoolkit becouse it isn't in beta and appeared more stable to me. I chose the version of Linux almost randomly, and didn't think that the virtualization could be a problem, but if any of these thing is a problem please tell me.

I downloaded the linux version of ARtoolkit and extracted it on the desktop. Then I ran the ./Configure executable and said no to everything exept Video4Linux2, because my teacher told me to do so. He also warned me the Linux distro could miss some of the libraries, so I used the apt-get command to download the necessary libraries when the make stopped. I ran the following instruction:

sudo apt-get install cmake
sudo apt-get install libc++1
sudo apt-get install libstdc++
sudo apt-get install g++
sudo apt-get install xorg
sudo apt-get install libjpeg-dev
sudo apt-get install freeglut3
sudo apt-get install freeglut3-dev
sudo apt-get install libv4l2-0-dev
sudo apt-get install libv4l2-0
sudo apt-get install libdc1394-22-dev
sudo apt-get update
sudo apt-get install libv4l-dev
sudo apt-get install libopencv-dev
sudo apt-get install libdc1394-22
sudo apt-get install libdc1394-22-dev
sudo apt-get install libxmu-dev
sudo apt-get install libglew1.5-dev
sudo apt-get install libXi-dev

and for each one of those the make proceeded and stopped telling me a .h file was missing. For each one I looked for the solution on internet and solved the problem with the next instruction. Anyway, the last error that stop the make doesn't involve any library. After a bit of computing, the make stops because a g++ command on calib_camera.o fails.
I get a lot (really a lot) of messages saying there are undefined references in the files calib_camera.cpp and video2.c. Then it says:
collec2: error: ld returned 1 exit status
and the make end with 1 as well.
I can definitely tell something doesn't work but I can't tell how. I thought from the names of the files that there is a problem with the operCV libraries, but their installation gave no errors and I can't find any update for it.

Please, can someone here tell me what's going on? Has all this already happened to someone here? Do you know a way to fix it? I can give you a more detailed view on the errors if needed.
I don't mind to change the Linux distribution or the version of ARtoolkit.

Sorry if I did any english mistakes writing this, it's not my mothertongue.

Return to “ARToolKit for Desktop v5.x”

Who is online

Users browsing this forum: No registered users and 1 guest