Issue with loading opencv_core.2.2.0.dylib

Archived discussions on ARToolKit NFT (version 3 and variants)
patrickoshaughnessey
Posts: 14
Joined: Thu May 28, 2009 11:08 am

Issue with loading opencv_core.2.2.0.dylib

Postby patrickoshaughnessey » Tue Jun 28, 2011 10:26 am

Hello,

I followed the installation instructions for ARToolkit4 Pro and ARToolkitNFT. Both projects compile fine, however, when attempting to run the NFT examples, I get the following error:

Code: Select all

dyld: Library not loaded: @executable_path/libopencv_core.2.2.0.dylib
  Referenced from: /Users/poshaughnessey/dev/ARToolKitNFT-bin-3.50.0-MacOSX-Universal/bin/exampleNFT0.app/Contents/MacOS/exampleNFT0
  Reason: image not found


Any help would be much appreciated.

Thanks,
Patrick

patrickoshaughnessey
Posts: 14
Joined: Thu May 28, 2009 11:08 am

Re: Issue with loading opencv_core.2.2.0.dylib

Postby patrickoshaughnessey » Tue Jun 28, 2011 12:14 pm

Okay, I was able to get exampleNFT0 to work by doctoring the XCode project in the following way:
    1) Add all of the libopencv_*dylib files in "lib/macosx-universal", and "OpenCV.framework/Versions/A/OpenCV" to the projegt
    2) Add a "Copy files" target that copies all of the libopencv_*dylib files to the "Products Directory"
    3) Add a "Copy files" target that copies "OpenCV" to the "Frameworks" destination with a subpath of "OpenCV.framework/Versions/A"

The XCode project should probably be updated in the distribution, unless I am doing something horribly wrong that required me to do these extra steps.

Thanks,
Patrick

User avatar
philip_lamb
Site Admin
Posts: 660
Joined: Thu Mar 09, 2006 8:35 pm

Re: Issue with loading opencv_core.2.2.0.dylib

Postby philip_lamb » Thu Jul 07, 2011 12:13 am

Patrick,

Thanks for the bug report. A lot of things were being moved around when packaging this version of the SDK, and it looks like the build phase where the dylibs are copied into the app bundle got lost there somewhere. We've fixed this for the next release.

davidje13
Posts: 1
Joined: Thu Oct 13, 2011 5:32 am

Re: Issue with loading opencv_core.2.2.0.dylib

Postby davidje13 » Thu Oct 13, 2011 5:39 am

Hi, I have the same problem but I can't get the solution to work. OpenCV copies correctly, but the libopencv... files are not copied over, seemingly because the "Products Directory" target is empty (or possibly set to a random location which I haven't found).

Can you offer me any more help?

Thanks,
David


Return to “[ARCHIVED] ARToolKit NFT (v3.x)”

Who is online

Users browsing this forum: No registered users and 2 guests