osgviewer doesn't load animations and nor does the Android app

Community support forum for users of the GPL-licensed osgART Standard Edition v1.0 and proprietary-licensed osgART Professional Edition v1.1
Ayush P Vora
Posts: 2
Joined: Sun Nov 29, 2015 7:15 am

osgviewer doesn't load animations and nor does the Android app

Postby Ayush P Vora » Mon Nov 30, 2015 6:14 am

Hi all,

First of all, I'm a beginner; very beginner.

I got the arNativeOsg Android up and running on device and quite well, it displays the fighter jet in the example (p51d-jw-animated.osg https://github.com/artoolkit/artoolkit5/blob/master/EclipseProjects/ARNativeOSG/assets/OSG/p51d-jw-animated.osg) along with animation.
Afterwards, I converted some .fbx files to .osg and tried loading them in the app. While some of them even failed to convert (see http://www.artoolkit.org/community/forums/viewtopic.php?f=10&t=4747), all the ones that successfully converted were successfully rendered both on the osgviewer and the Android app but they weren't animating.
On opening the converted .osg files, I saw that the format for them was different compared to the fighter jet .osg that came sampled with the example app source. Hence, I tried to convert my .osg files to the format of the .osg that animated (the fighter jet one). However, I understand this might not be the reason it ain't animating.
While I do remember seeing another post that requested help on the same issue (no animation playing), I create another one. Somebody please help.

Please find attached some of our .osg files that we got using osgconv.
Attachments
Spinal.zip
(8.97 MiB) Downloaded 123 times
handgun_osg.zip
(1.34 MiB) Downloaded 107 times

Return to “[ARCHIVED] osgART Standard & Professional Editions”

Who is online

Users browsing this forum: No registered users and 2 guests