CMake Error- osg version not found

Community support forum for users of the GPL-licensed osgART Standard Edition v1.0 and proprietary-licensed osgART Professional Edition v1.1
mechanix
Posts: 1
Joined: Wed Dec 11, 2013 11:34 am

CMake Error- osg version not found

Postby mechanix » Wed Dec 11, 2013 11:51 am

Hi,
I built OpenSceneGraph-3.2.0, successfully. In cmaKe I'm getting the following error while building osgART(E:\AR\osgART)

Code: Select all

CMake Warning at C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindOpenSceneGraph.cmake:135 (message):
  [ FindOpenSceneGraph.cmake:135 ] Failed to parse version number, please
  report this as a bug
Call Stack (most recent call first):
  CMakeLists.txt:37 (find_package)

CMake Error at C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
  Could NOT find OpenSceneGraph: Found unsuitable version "..", but required
  is at least "3.2.0" (found --libs
Call Stack (most recent call first):
  C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:313 (_FPHSA_FAILURE_MESSAGE)
  C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindOpenSceneGraph.cmake:187 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:37 (find_package)

With osg-3.3.0 developer version, having same errors.
I have checked out osgART from the link given in osgART.org. I'm using VS2012 in windows 7 64-bit.

Any help is appreciated.

Regards.
Regards

Return to “[ARCHIVED] osgART Standard & Professional Editions”

Who is online

Users browsing this forum: No registered users and 2 guests